Go Back  PPRuNe Forums > Misc. Forums > PPRuNe Problems or Queries
Reload this Page >

Cannot access PPRuNe due to the Trustarc GDPR login cookie pop-up

PPRuNe Problems or Queries The home for site specific queries and comments on PPRuNe desktop and mobile.

Cannot access PPRuNe due to the Trustarc GDPR login cookie pop-up

Old 17th Aug 2020, 16:44
  #1 (permalink)  
Thread Starter
 
Join Date: Jul 2000
Location: Peripatetic
Posts: 10,715
Cannot access PPRuNe due to the Trustarc GDPR login cookie pop-up

Pprune has obviously just updated their security/GDPR software and its preventing me accessing the site.

When I access the site I get a window headed "We Value Your Privacy" and saying a list of items has to be selected Yes or No before proceeding. Unfortunately there is also the classical spinning circle and no list, so I get stuck at that point.

I have deleted all cookies and site history and the same occurs when I try again, I have deleted all and then rebooted the iPad - same result.

Anyone any suggestions?

p.s. Same happened here on my iMac but it shows the lists, allows me to select yes and proceed to the site.
ORAC is offline  
Old 17th Aug 2020, 16:56
  #2 (permalink)  
 
Join Date: Oct 2015
Location: UK
Posts: 162
Cookie popup

The popup with the cookie / privacy questions seems to have changed today. Unfortunately this doesn't work correctly with Safari on the mac. It is fine with Firefox, but that isn't the browser that I normally use (Safari is the Apple supplied browser on the mac, so I'm guessing that I'm not the only one with the problem). Can it be fixed please?



Hermite is offline  
Old 17th Aug 2020, 17:02
  #3 (permalink)  
Thread Starter
 
Join Date: Jul 2000
Location: Peripatetic
Posts: 10,715
OK, solved by going into Safari-advanced-Delete all website data.
ORAC is offline  
Old 17th Aug 2020, 17:06
  #4 (permalink)  
 
Join Date: Oct 2002
Location: West Wiltshire, UK
Age: 67
Posts: 390
Not just an iPad, I cannot access PPRuNe from my usual browser on a PC, either. To be able to post this I've had to fire up an old Windows 7 PC, connect using a VPN and that's enabled me to try and see what's going on.

The problem seems to be with something called Trustarc. It's not completing a script, so hangs with some sort of GPDR compliance window, just displaying the "loading" thing. My limited looking around seems to show that it's definitely the Trustarc thing that's causing the site to just lock up. I've tried clearing cookies, restarting the browser, all the usual stuff, but the only way I've been able to get in to post this is by firing up an old, and fairly insecure, Win 7 machine, that's running Palemoon as the browser. Even then I have had to "allow everything" to get this to work.

The Trustarc script hang is before the lists show, so there is no way to access anything at all. The whole site is greyed out behind the Trustarc pop-up, with no way that I can find to clear it.
VP959 is online now  
Old 17th Aug 2020, 17:09
  #5 (permalink)  
 
Join Date: Sep 2009
Location: UK
Posts: 4,391
I'm getting the screen shot on my mobile. Not every time
Kiltrash is online now  
Old 17th Aug 2020, 17:31
  #6 (permalink)  
 
Join Date: Apr 2019
Location: EDSP
Posts: 294
Yes, broken here on Chromium as well. Circle of death.
BDAttitude is offline  
Old 17th Aug 2020, 17:33
  #7 (permalink)  
 
Join Date: Oct 2002
Location: West Wiltshire, UK
Age: 67
Posts: 390
Cannot access PPRuNe from PC running Firefox

Same issue as reported in the thread re: access from an iPad. There's a problem with the new Trustarc GDPR thing, that seems to cause a script to hang, blocking the site completely. This is a screenshot showing the problem (the "loading" wheel just perpetually spins):




Clearing cookies, all cached data, disabling all browser add-ons, restarting the browser etc doesn't fix it, the only way I can get access to PPRuNe at the moment is by using an old PC that's running Palemoon on Windows 7. It seems as if it may be browser specific, although in this post there's mention of a similar problem with an iPad: https://www.pprune.org/computer-inte...rune-ipad.html

I've run out of things to try, now, so am guessing that it may be something within the Trustarc feature that isn't 100% compatible with all browsers. In case it's any help in diagnosis, the Trustarc pop-up didn't appear at all on this old PC running the Palemoon browser, it seems only to pop-up in Firefox (haven't yet tried Safari, will have a look as soon as my wife's stopped using the Mac).
VP959 is online now  
Old 17th Aug 2020, 17:46
  #8 (permalink)  
 
Join Date: Feb 2006
Location: Station 42
Age: 65
Posts: 878
I had the same until I logged in, then it disappeared.
Running Opera on W10.
stevef is offline  
Old 17th Aug 2020, 17:49
  #9 (permalink)  
 
Join Date: Feb 2016
Location: Southport
Posts: 1,130
It hangs on my ipad mini, but can get in past the prompt on Firefox mobile on my Android phone. Took two goes for the options to appear though.
andytug is offline  
Old 17th Aug 2020, 17:52
  #10 (permalink)  
 
Join Date: Oct 2002
Location: West Wiltshire, UK
Age: 67
Posts: 390
The snag I have is that the Firefox browser just locks up, as in that photo, so won't let me log in. For some odd reason Palemoon seems unaffected, no idea why. I've been able to log in on this old Win 7 machine, using Palemoon, with no problem. However, if I try and use Firefox, even on this Win 7 machine, I get the same screen as above, just locked up with that pop-up permanently trying to load. I've tried over a dozen times now, clearing everything down, restarting the browser, etc, but with the same result.
VP959 is online now  
Old 17th Aug 2020, 17:54
  #11 (permalink)  
 
Join Date: Feb 2006
Location: Station 42
Age: 65
Posts: 878
When I came back the box was there again and the page lightly greyed out. I mouse clicked a margin and everything came back to normal.
stevef is offline  
Old 17th Aug 2020, 17:55
  #12 (permalink)  
 
Join Date: Jan 2007
Location: UK
Posts: 492
iPad using Safari I can’t access
No problem using DuckDuckGo
NRU74 is offline  
Old 17th Aug 2020, 17:58
  #13 (permalink)  
 
Join Date: Oct 2002
Location: West Wiltshire, UK
Age: 67
Posts: 390
Just tried that. Sadly didn't work, the screen is still greyed out, with that pop-up box trying to load. This time it did let me log in before locking up, though, and I thought for a moment the problem had been fixed! I'm at a loss to try and understand exactly what's going wrong, but suspect it must be that Trustarc thing trying to do something that the browser can't cope with. In my case, the browser that's giving the problem is Firefox 79.0, so it's up to date.

VP959 is online now  
Old 17th Aug 2020, 18:17
  #14 (permalink)  
 
Join Date: Oct 2002
Location: West Wiltshire, UK
Age: 67
Posts: 390
Further to this, I can now confirm that it seems to be region specific. I'm currently logged in using Firefox, with no problems at all, but I had to use a VPN so that it looks as if I'm in Canada (I'm not, I'm in the UK).

I think this confirms that the problem lies with the Trustarc GDPR gizmo, as that seems to try to detect the region of the world you log in from, and if it thinks you're in the EU it will try and pop-up the windows that seems to just hang, and block access to PPRuNe.

So, the workaround, for anyone having this problem, and who is currently located within the EU, is to use a VPN to spoof their location so that they appear to be somewhere else. Don't think it matters much where, as long as it's outside the EU.
VP959 is online now  
Old 17th Aug 2020, 18:25
  #15 (permalink)  
 
Join Date: Mar 2012
Location: West Yorkshire
Age: 51
Posts: 1
Just had this issue with Google Chrome - CTRL F5 to force reload and then clicking the page reload icon at top left cleared it for me......
Cafe john is offline  
Old 17th Aug 2020, 18:31
  #16 (permalink)  
 
Join Date: Jan 2007
Location: UK
Posts: 492
Using a late(ish) iPad
DuckDuckGo No problem with or without a VPN
Safari with a VPN (ipvanish) can’t get on
Start Page ditto
NRU74 is offline  
Old 17th Aug 2020, 18:36
  #17 (permalink)  
 
Join Date: Oct 2002
Location: West Wiltshire, UK
Age: 67
Posts: 390
Originally Posted by NRU74 View Post
Using a late(ish) iPad
DuckDuckGo No problem with or without a VPN
Safari with a VPN (ipvanish) canít get on
Start Page ditto
If you use a VPN service that allows you to select an apparent location outwith the EU I think you should find it works OK. I used NordVPN, and with my apparent location set to anywhere within the EU I get the lock-up problem, but as soon as I select an apparent location outwith the EU (i.e Canada) it works fine. I'm pretty sure that the rogue element, perhaps via a routine update, on the Trustarc thing that the forum is using is only blocking site access to some browsers for some users located within the EU. The odd thing is that it works fine on this old Windows 7 PC using Palemoon as the browser. No idea why.
VP959 is online now  
Old 17th Aug 2020, 18:40
  #18 (permalink)  
 
Join Date: Oct 2015
Location: UK
Posts: 162
I'm in the UK (currently EU regulations I think) and as I noted at the start the problem (at least for me) is browser related. I can scroll down the box in Firefox, but not in Safari.
Hermite is offline  
Old 17th Aug 2020, 18:48
  #19 (permalink)  
 
Join Date: Oct 2002
Location: West Wiltshire, UK
Age: 67
Posts: 390
Definitely browser specific for me, too. Palemoon on a old Win 7 machine is fine, Firefox gets the blocking and hung pop-up every time, unless I use a VPN to pretend to be outwith the EU, when Firefox works fine, with no problems.

Seems to me that the apparent location triggers the Trustarc thing initially, so no matter what browser you're using if PPRuNe thinks your outwith the EU then the blocking pop-up won't appear. If you do seem to be within the EU, then it seems that some browsers cannot deal with whatever it is that has changed within the Trustarc GPDR compliance feature. My guess is that Trustarc may have updated something today, and broken some core functionality with some browsers.
VP959 is online now  
Old 17th Aug 2020, 18:48
  #20 (permalink)  
 
Join Date: Dec 2014
Location: Midlands
Posts: 120
I just had the same, W10 and Chrome. It appears to be a cookie problem.

When I allowed second party cookies the pop up worked properly and allowed me to block the cookies. When the pop up disappeared I then reset Chrome to stop second party cookies. All seems to be working normally now.
Planet Basher is offline  

Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright © 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.