Go Back  PPRuNe Forums > Misc. Forums > PPRuNe Problems or Queries
Reload this Page >

Cannot access PPRuNe due to the Trustarc GDPR login cookie pop-up

PPRuNe Problems or Queries The home for site specific queries and comments on PPRuNe desktop and mobile.

Cannot access PPRuNe due to the Trustarc GDPR login cookie pop-up

Old 17th Aug 2020, 19:09
  #21 (permalink)  
 
Join Date: Jul 2000
Location: UK
Posts: 1,469
I get the same problem in Safari, Firefox and Chrome on a MacBook and on iOS devices. I can scroll down the box and click the 'required cookies' link but can't get beyond that.

Problem is not apparent using a non-uk VPN - somewhere in USA in my case.
Background Noise is offline  
Old 17th Aug 2020, 19:17
  #22 (permalink)  
 
Join Date: Jul 2020
Location: Beds
Posts: 2
Same issue with iPad using Chrome or Safari and MacBook using Chrome or Safari. Can only get in on MacBook using Tor Browser. Guess it's an EU thing.
Seaking74 is online now  
Old 17th Aug 2020, 19:30
  #23 (permalink)  
 
Join Date: Aug 2007
Location: West Yorkshire
Posts: 635
Using Chrome I can log in and the screen is bright. If I select a thread it acesses it but goes grey. The annoying box, with the perpetual hamster wheel disappears and I can read the thread albeit in grey. To whose notice does one bring this particular shortcoming to. Anyone know. Doesnt seem to be many Mods these days.
paully is offline  
Old 17th Aug 2020, 19:53
  #24 (permalink)  
 
Join Date: Mar 2013
Location: Cheltenham, UK
Posts: 113
Originally Posted by Planet Basher View Post
I just had the same, W10 and Chrome. It appears to be a cookie problem.

When I allowed second party cookies the pop up worked properly and allowed me to block the cookies. When the pop up disappeared I then reset Chrome to stop second party cookies. All seems to be working normally now.
Have you tried Ghostery? I've blocked all cookies including Trustmarc and no pop up :0)
BirdmanBerry is offline  
Old 17th Aug 2020, 19:54
  #25 (permalink)  
 
Join Date: Mar 2013
Location: Cheltenham, UK
Posts: 113
If you can use Chrome, add Privacy Badger extension and block Trustarc.
BirdmanBerry is offline  
Old 17th Aug 2020, 20:13
  #26 (permalink)  
 
Join Date: Oct 2002
Location: West Wiltshire, UK
Age: 67
Posts: 390
Just tried another laptop, same problem, PPRuNe is inaccessible using Firefox if I don't use a VPN and try and spoof my location as being outwith the EU. No problem when using Palemoon, but the problem seems to also be there with Chromium (the fully open source version of Chrome).

I've tried blocking cookies, makes no difference, it seems that there's something fundamentally broken within the Trustarc GDPR compliance feature, and from the fact that this only started happening this afternoon (BST) it looks rather as if it might be related to an update, perhaps. There's been no update to any of the browsers I've been using today.

Definitely not an obvious cookie problem, as I've cleared all cookies, the cache etc. The problem seems to be the Trustarc script hanging, part way through execution, with some browsers not behaving as the Trustarc script expects.
VP959 is online now  
Old 17th Aug 2020, 20:19
  #27 (permalink)  
 
Join Date: Apr 2008
Location: the dark side
Posts: 232
The only browser I have tried which works normally is one called Vivaldi.
Firefox, Chrome, Brave and Avast secure browser all get blocked by the popup.
horatio_b is offline  
Old 17th Aug 2020, 20:19
  #28 (permalink)  
 
Join Date: Jul 2014
Location: England
Posts: 295
The same thing seems to happen on a Windows 10 PC with old Internet Explorer but not with new Microsoft Edge. I don't have Chrome to hand because I normally use Firefox – but I've installed the NoScript extension, which I strongly recommend, which can selctively block Javascript. Install NoScript and trust PPRuNe.org (and ajax.googleapis.com, cloudflare,com, fastly.net) but not trustarc.com, and all's well in PPRuNe land.
OldLurker is offline  
Old 17th Aug 2020, 20:24
  #29 (permalink)  
 
Join Date: Jul 2014
Location: England
Posts: 295
As I mentioned on the other thread, if you're using Firefox, install the excellent NoScript extension and don't trust trustarc.com. Done.
OldLurker is offline  
Old 17th Aug 2020, 20:29
  #30 (permalink)  
 
Join Date: Oct 2002
Location: West Wiltshire, UK
Age: 67
Posts: 390
Thanks, BirdmanBerry , just tried this, installed the Privacy Badger extension to Firefox and it seems to have got rid of the broken pop-up window if Firefox and allows access to the forum again, without having to use a different PC/browser or spoof my location as being outwith the EU.
VP959 is online now  
Old 17th Aug 2020, 20:31
  #31 (permalink)  
Gnome de PPRuNe
 
Join Date: Jan 2002
Location: Too close to Croydon for comfort
Age: 56
Posts: 6,904
I've got the same problem on Win10/Chrome. Haven't tried using my android yet.

Clicking page back and page forward arrows seems to get around it...
treadigraph is online now  
Old 17th Aug 2020, 20:35
  #32 (permalink)  
 
Join Date: Oct 2002
Location: West Wiltshire, UK
Age: 67
Posts: 390
The workaround suggested by BirdmanBerry in this thread: https://www.pprune.org/computer-inte...l#post10863613 , to install the Privacy Badger extension, seems to work with Firefox as well as Chrome/Chromium.

It doesn't fix the fundamental flaw within the Trustarc script, as it just blocks the ability of PPRuNe to demonstrate compliance with the GDPR, so arguably it stops the forum from doing what it has to do, by law, within the EU. It is an easier workaround than either having to use a different device to browse PPRuNe or do something a bit out of the ordinary, like spoof your location using a VPN service.
VP959 is online now  
Old 17th Aug 2020, 20:36
  #33 (permalink)  
 
Join Date: Jan 2010
Location: France
Posts: 428
So far so good by using a VPN ... but not accessible without it using Firefox. PLEASE try to correct this ... you make my day
Alsacienne is online now  
Old 17th Aug 2020, 22:01
  #34 (permalink)  
 
Join Date: Mar 2011
Location: Hoofddorp The Netherlands
Age: 66
Posts: 56
Have Firefox and Windows 10,took approx. 5 minutes to gain access
spitfirek5054 is offline  
Old 17th Aug 2020, 22:41
  #35 (permalink)  
Administrator
 
Join Date: Dec 2013
Location: LA
Posts: 1,158
Thank you for reporting -- we are looking into this!
IBobi is offline  
Old 17th Aug 2020, 23:34
  #36 (permalink)  
 
Join Date: May 2009
Location: Search me - I only just got out of bed ....
Age: 75
Posts: 475
Seems to be fine down here in my part of Oz (using Firefox and Windows with 'remember me' automatic sign in to this essential service).
FullOppositeRudder is offline  
Old 18th Aug 2020, 06:46
  #37 (permalink)  
 
Join Date: Jan 2010
Location: France
Posts: 428
THANK YOU FOR FIXING THIS!!! Life is back to what passes for normal!!!
Alsacienne is online now  
Old 18th Aug 2020, 07:48
  #38 (permalink)  
Gnome de PPRuNe
 
Join Date: Jan 2002
Location: Too close to Croydon for comfort
Age: 56
Posts: 6,904
I clicked the accept button eventually though somewhat reluctant to do so as I didn't know what it was...
treadigraph is online now  
Old 18th Aug 2020, 09:03
  #39 (permalink)  
 
Join Date: Oct 2002
Location: West Wiltshire, UK
Age: 67
Posts: 390
Originally Posted by FullOppositeRudder View Post
Seems to be fine down here in my part of Oz (using Firefox and Windows with 'remember me' automatic sign in to this essential service).
I'm pretty sure it only impacted those in the EU, as the pop-up in question only seemed to pop-up and hang if the device being used either was, or appeared to be, within the EU. Using a VPN to spoof one's location to somewhere outwith the EU solved the problem. From what I found out yesterday, the Trustarc pop-up is supposed to be a tool to allow websites to demonstrate compliance with the EU General Data Protection Regulations, GDPR, when it works as it's supposed to. It looks as if something within the Trustarc add-on stopped working properly with some, but not all, web browsers, but this would probably only affect those of us in Europe.
VP959 is online now  
Old 18th Aug 2020, 10:12
  #40 (permalink)  
 
Join Date: Aug 2020
Location: Far East
Posts: 18
Windows 10 Edge Chromium worked here
Chrome Browser on Android worked here
I selected once in each and all was done.
waito is offline  

Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.